Hi,

 

I would guess this might be related to a bug that is listed as fixed as of the 1.5.1 version.  Here is the text from change-log  

 

- BUG: TSVNCache could end up in an endless loop and use all CPU if a working
       copy was placed in a root path, e.g., C:\ (Jacques Lemire)

 

I had behavior like the above bug so I just installed 1.5.6 Build 14908 hoping to resolve. I did not.   I can find no further discussion of this topic in the task data base.   

 

My problem is that when I open my PC explorer window   to the top directory of the directory hierarchy of the working copy I get the following (Top being the first directory with a .svn directory in it)

1.       The explorer window repeatable refreshes.  It shows the directory file list, starts adding green checks to the icons, then the window goes blank, then it shows the directories again, starts drawing the icons then repeates. Just cycles like that forever.

2.       The TSVNCache.exe process starts running at 20% cpu and runs forever.  I have let this process run for hours and it never settles down.

 

If I am above this directory I see a nice folder icon with a green check box.  If I am below the “top” directory everything seems to work fine.  I can descend down all four or so levels of hierarchy and add, commit, update just fine.  Just at that top level it goes into infinite loop.   Once I have hit that directly TSVNCache will continue at 20% load forever, no matter even if I close the browswer window.  This working copy is buried way down in my personal account file hierarchy on the file server. 

 

It happens if I access this file directory from a URL \\filer\homes\jkuhn\designs\....  

The same behavior happens if I make a PC mount point of the directory  (O:\designs\...)

 

I thought it maybe do to non-version strange files or a corrupted file.  However I built a completely new working copy and issues one update command and I still get the behavior.

 

Here are more details of my setup.  One suspicion I have is that the working copy is on a network file share.  I not the bug above said a root directory.   

 

 

Here are more details of my setup.  It maybe a little unique but it all seems to work well except for this endless looping.

 

  1. The svn working copy sits in my user account on our corporate file server.   I cannot tell you at the moment exactly what that hardware it is.  It hosts all our files, Linux and windows users.  My guess is it is a Linux system hacked to handle Windows files because it does not really get Windows 100% correct (It has limited ACLS compared to normal windows)
  2. This is true of the SVN repository as well.  
  3. The svn working copy is usually managed from our Linux machines and is using svn+ssh://svnhost/….  Protocol to access the repository.
  4. which svn: subversion-1.5.2, reasonably up to date.
  5. I am using my windows PC (Windows XP Pro, SP2) with Tortoise SVN installed to browse my working area. Now 1.5.6
  6. This all has worked pretty well.   I can update, add, commit from my PC and have no issue.
  7. My working copy and the tree managed by svn is reasonably large.  It it about 4 levels deep and looks like the following.  I will need to refer to these levels of hierarchy to describe exactly what is happening.

 

 

Any help would be appreciated.  I would like to roll this out as a way for my group to access their documentation but cannot with this behavior.

 

Sincerely,

 

Jay