Login | Register
My pages Projects Community openCollabNet

Discussions > users > RE: revert seems to do nothing... ?

Project highlights: :. Download .: :. Support .: :. FAQ .: :. Translations .: :. Donate .: :. Report Bug .:

tortoisesvn
Discussion topic

Back to topic list

RE: revert seems to do nothing... ?

Author "Bob Archer" <Bob dot Archer at amsi dot com>
Full name "Bob Archer" <Bob dot Archer at amsi dot com>
Date 2009-01-05 13:05:04 PST
Message Hmm... I'm not so sure if you can revert an add. I've never tried
this... since this is really a reverse merge and there is no previous
version for that file.

Bob


> -----Original Message-----
> From: postmaster at tigris dot org [mailto:postmaster at tigris dot org]
> Sent: Monday, January 05, 2009 3:27 PM
> To: users at tortoisesvn dot tigris dot org
> Cc: jason at spiritsentient dot com
> Subject: revert seems to do nothing... ?
>
> greetings all!
>
> my name's jason, nice to meet you all. i'm just getting my feet wet
> with subversion, and tortoise has helped soooooo much with amazing
> documentation and a *great* client. i can really feel the love :)
>
> i have a problem, i'm sharing it in the hopes someone can help, or it
> helps others :)
>
>
> ***************
>
> i currently have a working copy (d:\websites\myworkingcopy)
>
> the structure of myworkingcopy is: the root of my website and
subfolders
> (wordpress, images, etc.) (no trunk/branches/tags -- this working
folder
> IS the trunk)
>
>
> i also have a repository setup at this URL
(svn.myrepository.com/repo)
>
>
> the structure of the repository is trunk/branches/tags (i imported my
data
> to the repository and it either decided to place the data in "trunk"
or i
> specified it like so: svn.myrepository.com/repo/trunk during the
import.
> (can't recall exactly.)
>
> i checked out a working copy (d:\websites\myworkingcopy), added a file
> (xtrafile.txt) and comitted it. worked great.
>
> i added another file (xtrafile2.txt), and it also worked great.
everything
> green check marked, 2 new revisions in my log, perfect.
>
>
>
> now i want to RollBack or Revert or Undo those 2 revisions so my
working
> copy is back to square 1 with no "Xtrafiles.txt" in it.
>
> it seemed sooo straight forward, choose correct parent folder, browse
the
> log, right-click and "revert changes", or "revert to this revision" or
> even... "merge"? and that alters the working copy from what i
understand
> and i just *commit* the working copy and it should work, yes?
>
>
> i've tried everything and no matter what i do both the repository AND
> working folder still contain Xtrafiles.txt and the Revision# is still
the
> same, and everything is Unmodified with No Chages To Commit.
>
>
>
> thanks so much for reading, i love subversion and i am currently not
> benefiting from its awesomeness.
>
> take care,
> -j.
>
> --------------------​--------------------​--------------
>
http://tortoisesvn.t​igris.org/ds/viewMes​sage.do?dsForumId=40​61&dsMessage
Id
> =1005981
>
> To unsubscribe from this discussion, e-mail: [users-
> unsubscribe@tortoise​svn.tigris.org].

« Previous message in topic | 3 of 10 | Next message in topic »

Messages

Show all messages in topic

revert seems to do nothing... ? postmaster at tigris dot org postmaster at tigris dot org 2009-01-05 12:27:08 PST
     Re: revert seems to do nothing... ? jeanmarc Jean-Marc van Leerdam 2009-01-05 13:03:57 PST
     RE: revert seems to do nothing... ? "Bob Archer" <Bob dot Archer at amsi dot com> "Bob Archer" <Bob dot Archer at amsi dot com> 2009-01-05 13:05:04 PST
         Re: revert seems to do nothing... ? "Jason Fonceca" <jason at spiritsentient dot com> "Jason Fonceca" <jason at spiritsentient dot com> 2009-01-06 07:23:46 PST
         Re: revert seems to do nothing... ? "Simon Large" <simon dot tortoisesvn at googlemail dot com> "Simon Large" <simon dot tortoisesvn at googlemail dot com> 2009-01-06 08:21:27 PST
             RE: revert seems to do nothing... ? "Bob Archer" <Bob dot Archer at amsi dot com> "Bob Archer" <Bob dot Archer at amsi dot com> 2009-01-06 08:27:29 PST
                 Re: revert seems to do nothing... ? "Simon Large" <simon dot tortoisesvn at googlemail dot com> "Simon Large" <simon dot tortoisesvn at googlemail dot com> 2009-01-06 08:37:49 PST
     Re: revert seems to do nothing... ? "Simon Large" <simon dot tortoisesvn at googlemail dot com> "Simon Large" <simon dot tortoisesvn at googlemail dot com> 2009-01-06 01:31:09 PST
     RE: revert seems to do nothing... ? postmaster at tigris dot org postmaster at tigris dot org 2009-01-06 09:35:21 PST
         RE: revert seems to do nothing... ? "Bob Archer" <Bob dot Archer at amsi dot com> "Bob Archer" <Bob dot Archer at amsi dot com> 2009-01-06 09:53:13 PST
Messages per page: