Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: svn:ignore Issues in Windows Vista

Project highlights: :. Download .: :. Support .: :. FAQ .: :. Translations .: :. Donate .: :. Report Bug .:

tortoisesvn
Discussion topic

Back to topic list

Re: svn:ignore Issues in Windows Vista

Author kkolinko
Full name Konstantin Kolinko
Date 2009-01-09 15:56:47 PST
Message 2009/1/9 Jason Cavett <jason dot cavett at gmail dot com>:
> I'm referring to the /bin folder that is created by Eclipse (not
> Visual Studio). Basically, my folder structure is something like
> this...
>
> Project
> src
> bin
> resources
> lib
>
> Basically, I check in the top-level Project directory (because I want
> src, resources and lib to be included in SVN). The bin directory is
> created when the src is built in Eclipse. When I sync with the SVN
> server, Tortoise wants to add bin (since it is a newly created
> directory). However, I just tell it to ignore bin. This works in
> Windows XP, but does not appear to work in Vista.
>
> (...)
> I'm still having this issue. After seeing some other bug posts, I
> don't believe the issue is with svn:ignore. I instead think it has to
> do with how Vista handles (or doesn't handle) the overlay icons.
>
> Anybody else have any issues with Vistas overlay icons.
>

Please note, that Java Builder of Eclipse IDE sometimes confuses .svn
folders and files in them in your source folder as resources and
copies them into /bin. Thus, /bin becomes a nested working copy.

Because *.java files are not copied and are missing, its status is "modified".


Also, sometimes that "copy" is corrupted, because some files are
missing from the copied .svn folders, or were overwritten if the /bin
folder itself belongs to Subversion or if you have several source
folders.

I do not know, whether your Vista shows those .svn subfolders or not.
You can check the Subversion tab of the properties dialog for the /bin
folder, and Check for modifications dialog in TortoiseSVN.

It does not depend on the operating system, but on how lucky you are
and what actions you do perform. I think that there is a race
condition between the team plugin (Subclipse, Subversive - I observed
the problem with both of them) and the java builder. You are more
likely to see it after performing Import of Existing Project.

My current solution whenever I encounter it is to 1. Delete project
from the workspace, 2. Delete all files from /bin folder, or better
the folder itself, 3. Turn automatic compilation off, 4. Import
project, 5. Wait until all svn indexing completes. 6. Turn automatic
compilation on.


Best regards,
Konstantin Kolinko

« Previous message in topic | 6 of 6 | Next message in topic »

Messages

Show all messages in topic

svn:ignore Issues in Windows Vista Jason Cavett <jason dot cavett at gmail dot com> Jason Cavett <jason dot cavett at gmail dot com> 2008-12-28 13:23:14 PST
     Re: svn:ignore Issues in Windows Vista "Simon Large" <simon dot tortoisesvn at googlemail dot com> "Simon Large" <simon dot tortoisesvn at googlemail dot com> 2008-12-28 16:13:37 PST
     Re: svn:ignore Issues in Windows Vista brendan <bkeyhoe1 at gmail dot com> brendan <bkeyhoe1 at gmail dot com> 2008-12-29 09:00:21 PST
         Re: svn:ignore Issues in Windows Vista Jason Cavett <jason dot cavett at gmail dot com> Jason Cavett <jason dot cavett at gmail dot com> 2008-12-29 09:11:44 PST
     Re: svn:ignore Issues in Windows Vista Jason Cavett <jason dot cavett at gmail dot com> Jason Cavett <jason dot cavett at gmail dot com> 2009-01-09 10:01:39 PST
         Re: svn:ignore Issues in Windows Vista kkolinko Konstantin Kolinko 2009-01-09 15:56:47 PST
Messages per page: