Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: error stealing lock in TSVN 1.5.8

Project highlights: :. Download .: :. Support .: :. FAQ .: :. Translations .: :. Donate .: :. Report Bug .:

tortoisesvn
Discussion topic

Back to topic list

Re: error stealing lock in TSVN 1.5.8

Author steveking
Full name Stefan Küng
Date 2009-03-05 00:19:23 PST
Message Todd C. Gleason wrote:
> While running a test, I tried stealing a lock using TortoiseSVN 1.5.8
> and I got an error that the file was locked. It was the same error I
> get if I don’t check “steal the locks”:
>
>
>
> Command: Lock
>
> Error: Path '[path]' is already locked by user '[user]'
>
> Error: in filesystem '[svn internal path]'
>
> Finished!:
>
>
>
> I’m pretty sure this worked back in TortoiseSVN 1.5.3. The server is 1.5.2.
>
>
>
> Also, the Subversion 1.5.5 client, with option “—force”, seems to handle
> this fine and steals the lock as requested. Another workaround is to
> use the repo-browser to break the lock first.
>
>
>
> Is it possible that the “steal the locks” checkbox is being ignored?

I've tried this with the latest nightly build, and it works as expected.
And I don't see anything in my 1.5.x files that would suggest that the
checkbox is ignored.

Could you maybe try a nightly build?

Stefan

--
       ___
  oo // \\ "De Chelonian Mobile"
 (_,\/ \_/ \ TortoiseSVN
   \ \_/_\_/> The coolest Interface to (Sub)Version Control
   /_/ \_\ http://tortoisesvn.net
Attachments

« Previous message in topic | 2 of 4 | Next message in topic »

Messages

Show all messages in topic

error stealing lock in TSVN 1.5.8 tgleason Todd C. Gleason 2009-03-04 15:57:58 PST
     Re: error stealing lock in TSVN 1.5.8 steveking Stefan Küng 2009-03-05 00:19:23 PST
         RE: error stealing lock in TSVN 1.5.8 tgleason Todd C. Gleason 2009-03-06 11:43:08 PST
             Re: error stealing lock in TSVN 1.5.8 steveking Stefan Küng 2009-03-06 12:11:42 PST
Messages per page: