Login | Register
My pages Projects Community openCollabNet

Discussions > users > re: Re: Overlay icons - strange behaviour on some Win7 x64

Project highlights: :. Download .: :. Support .: :. FAQ .: :. Translations .: :. Donate .: :. Report Bug .:

tortoisesvn
Discussion topic

2020-03-13: This site is going to be decommissioned and shut down very soon. Please copy and archive any data you wish to keep ASAP

Back to topic list

re: Re: Overlay icons - strange behaviour on some Win7 x64

Author "Sebastian Grottel" <sebastian at grottel dot net>
Full name "Sebastian Grottel" <sebastian at grottel dot net>
Date 2009-09-19 00:48:40 PDT
Message On 2009-09-17 12:32:58 PDT, Stefan Küng wrote:
> > Recently I upgraded my two machines (business and private) to Windows 7
> > (both x64).
> >
> > While my private machine just works fine (i.e. all overlay icons are
> > showing like they should) on my business machine I get almost no overlay
> > icons!
> >
> > Almost!
> >
> > All Icons for ignored files are shown.
> >
> > When I add files, they show the add icon.
> >
> > When I commit my changes the add icon disappears but no other overlay
> > icon is shown.
> >
> > The “changed” overlay icon is shown for folders containing changed
> > files, but only in the Treeview , not in the Listview of the explorer.
> >
> > Files do never show the “changed” icon.
>
> Even if you hit F5 to refresh the view?

Yes, I can hit F5 as often as I want. The icons do not appear.

> > Both machines had their data (including the working copies) stored in a
> > backup and copied back, after Windows 7 was installed.
>
> If you copied the working copies back, then most likely the permissions
> are messed up. Right-click on the top folder, choose "properties" from
> the context menu (the explorer properties entry, not the one from TSVN).
> Go to the "Security" tab, click on "Edit...". Select yourself (the user
> as which you're logged on should be visible in the top list), then give
> yourself "full control" in the bottom list, click "Apply".
>
> If your user isn't listed, click on "Add..." and add yourself first.

I totally agree with you that the right are probably causing the trouble,
but I have the same problem with freshly checked out working copies too.
Why?

I continued to observe the behavior and I believe that the folders correctly
show the "changed" overlay, if they contain changes (only in the Treeview,
not in the Listview).

Yours,
Sebastian.

« Previous message in topic | 4 of 10 | Next message in topic »

Messages

Show all messages in topic

Overlay icons - strange behaviour on some Win7 x64 "Sebastian Grottel" <grottel at vis dot uni-stuttgart dot de> "Sebastian Grottel" <grottel at vis dot uni-stuttgart dot de> 2009-09-17 00:27:52 PDT
     Re: Overlay icons - strange behaviour on some Win7 x64 steveking Stefan Küng 2009-09-17 12:32:58 PDT
     RE: Overlay icons - strange behaviour on some Win7 x64 pilotbob Bob Archer 2009-09-17 13:26:13 PDT
     re: Re: Overlay icons - strange behaviour on some Win7 x64 "Sebastian Grottel" <sebastian at grottel dot net> "Sebastian Grottel" <sebastian at grottel dot net> 2009-09-19 00:48:40 PDT
     RE: RE: Overlay icons - strange behaviour on some Win7 x64 "Sebastian Grottel" <grottel at vis dot uni-stuttgart dot de> "Sebastian Grottel" <grottel at vis dot uni-stuttgart dot de> 2009-09-19 00:49:28 PDT
         RE: RE: Overlay icons - strange behaviour on some Win7 x64 joaopsf Joao Pedro Francese 2009-09-21 18:55:41 PDT
             RE: RE: Overlay icons - strange behaviour on some Win7 x64 grottel at vis dot uni-stuttgart dot de grottel at vis dot uni-stuttgart dot de 2009-09-21 23:47:58 PDT
             AW: RE: Overlay icons - strange behaviour on some Win7 x64 "Sebastian Grottel" <grottel at vis dot uni-stuttgart dot de> "Sebastian Grottel" <grottel at vis dot uni-stuttgart dot de> 2009-09-28 02:01:09 PDT
                 Re: Overlay icons - strange behaviour on some Win7 x64 "Andre dot Ziegler" <MagicAndre1981 at live dot com> "Andre dot Ziegler" <MagicAndre1981 at live dot com> 2009-09-28 04:52:20 PDT
                     AW: Overlay icons - strange behaviour on some Win7 x64 "Sebastian Grottel" <grottel at vis dot uni-stuttgart dot de> "Sebastian Grottel" <grottel at vis dot uni-stuttgart dot de> 2009-09-29 07:41:43 PDT
Messages per page: