Login | Register
My pages Projects Community openCollabNet

Discussions > users > SSL Handshake Failure in 1.6.11

Project highlights: :. Download .: :. Support .: :. FAQ .: :. Translations .: :. Donate .: :. Report Bug .:

tortoisesvn
Discussion topic

2020-03-13: This site is going to be decommissioned and shut down very soon. Please copy and archive any data you wish to keep ASAP

Back to topic list

SSL Handshake Failure in 1.6.11

Author Sumner Michael Smith <mike at smikesmith dot com>
Full name Sumner Michael Smith <mike at smikesmith dot com>
Date 2010-10-11 22:18:28 PDT
Message As others have reported, I, too, have experienced the SSL Handshake
failure when updating TortoiseSVN from 1.6.10 to 1.6.11.

I get the ...SSL handshake failed: SSL error code -1/1/336032856... for
any operation attempted with my private server on an existing working
source from a machine within local network. If I install 1.6.11, the
error persists and I cannot access the repository. Remove 1.6.11 and
install 1.6.10, it works as expected. I repeated this twice with the
same results, just to be sure it is repeatable.

Initially, I had submitted repository changes with 1.6.10 before
installing 1.6.11. After the install, the failure exhibited when I
attempted to browse, so I removed the install, rebooted, and installed
1.6.10. At that point, I could browse the repository again. Then I
updated a second time with 1.6.11, rebooted, and the problem reappeared.

Solution is to use 1.6.10 and turn off automatic update checks. The
error report of 1.6.11 is rather cryptic and is not directly copyable,
so I have only limited information. Server is Apache 2.2.16. No error
is logged by the server, but access log 'appears' (not rigorously
tested) to be only a subset when compared to a successful access with
1.6.10.

Never had the problem with any previous version of TSVN, at least in the
1.6 series, that I'm aware of. Has protocol changed in 1.6.11?

Mike Smith

« Previous message in topic | 1 of 4 | Next message in topic »

Messages

Show all messages in topic

SSL Handshake Failure in 1.6.11 Sumner Michael Smith <mike at smikesmith dot com> Sumner Michael Smith <mike at smikesmith dot com> 2010-10-11 22:18:28 PDT
     Re: SSL Handshake Failure in 1.6.11 levyam Andy Levy 2010-10-12 05:53:36 PDT
     Re: SSL Handshake Failure in 1.6.11 "Fredrik Orderud" <fredrik at orderud dot no> "Fredrik Orderud" <fredrik at orderud dot no> 2010-10-13 15:10:16 PDT
         Re: SSL Handshake Failure in 1.6.11 gcstang <gcstang at gmail dot com> gcstang <gcstang at gmail dot com> 2010-10-20 09:14:52 PDT
Messages per page: