Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: Re: Repository Browser not working

Project highlights: :. Download .: :. Support .: :. FAQ .: :. Translations .: :. Donate .: :. Report Bug .:

tortoisesvn
Discussion topic

Back to topic list

Re: Re: Repository Browser not working

Author simonlarge
Full name Simon Large
Date 2012-01-06 01:06:09 PST
Message On 6 January 2012 01:32, Robert Chapin <tigris at miqrogroove dot com> wrote:
>> That said, it does seem like the TSVN Repo Browser shouldn't need to
>> query the repo root if it's asked to browse a subdirectory. This does
>> seem like new behavior in TSVN 1.7.x--I seem to recall that in prior
>> versions, only the portions of the repo that are being displayed would
>> be queried--e.g., if you browsed
>> http://plugins.svn.w​ordpress.org/mailpre​ss, the tree on the left would
>> show mailpress as the only folder under the root. You would have to
>> navigate up one level for it to query the root and show all the folders.
>
> This :)  Because, if we can browse the individual projects, nobody cares what's in the repo root.
>
> Unfortunately, the solution does not seem to be as simple as drilling down another level.  When I try to pull up a trunk directory it still doesn't work, so that could mean it is still trying to look at the root.
>
> Might be related?  - BUG: Issue #146: Repo browser won't show a directory whose parent directory cannot be read.

I don't think so, it's simply the huge number of sub-directories in
that repository that is causing the server to be slow when queried
with the equivalent of svn st -v. There has already been some
discussion of this on the svn dev list:
http://svn.haxx.se/d​ev/archive-2012-01/0​053.shtml

Stefan already opened an issue on TSVN to use the faster svn st equivalent:
http://code.google.c​om/p/tortoisesvn/iss​ues/detail?id=180

Simon

--
:       ___
:  oo  // \\      "De Chelonian Mobile"
: (_,\/ \_/ \     TortoiseSVN
:   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
:   /_/   \_\     http://tortoisesvn.net

« Previous message in topic | 22 of 23 | Next message in topic »

Messages

Show all messages in topic

Repository Browser not working macmiller <turboblast88-1 at yahoo dot com> macmiller <turboblast88-1 at yahoo dot com> 2011-10-30 08:24:11 PDT
     Re: Repository Browser not working macmiller <turboblast88-1 at yahoo dot com> macmiller <turboblast88-1 at yahoo dot com> 2011-10-30 08:33:00 PDT
     RE: Repository Browser not working miqrogroove Robert Chapin 2012-01-05 12:31:38 PST
         Re: Repository Browser not working steveking Stefan Küng 2012-01-05 12:33:51 PST
             RE: Re: Repository Browser not working miqrogroove Robert Chapin 2012-01-05 14:51:22 PST
                 Re: Repository Browser not working Stefan Pendl <stefan dot pendl dot 71 at gmail dot com> Stefan Pendl <stefan dot pendl dot 71 at gmail dot com> 2012-01-05 14:54:16 PST
                     RE: Re: Repository Browser not working miqrogroove Robert Chapin 2012-01-05 16:21:49 PST
                         Re: Repository Browser not working Stefan Pendl <stefan dot pendl dot 71 at gmail dot com> Stefan Pendl <stefan dot pendl dot 71 at gmail dot com> 2012-01-05 16:29:28 PST
                             RE: Re: Repository Browser not working miqrogroove Robert Chapin 2012-01-14 12:57:45 PST
                                 Re: Repository Browser not working steveking Stefan Küng 2012-01-14 13:12:32 PST
                                     RE: Re: Repository Browser not working miqrogroove Robert Chapin 2012-01-16 02:17:32 PST
                                         Re: Repository Browser not working leak Kurt Pruenner 2012-01-16 02:43:43 PST
                                             Re: Repository Browser not working Dave Huang <khym at azeotrope dot org> Dave Huang <khym at azeotrope dot org> 2012-01-16 07:47:33 PST
                                                 Re: Repository Browser not working steveking Stefan Küng 2012-01-16 07:55:31 PST
                                                     RE: Re: Repository Browser not working miqrogroove Robert Chapin 2012-01-21 11:54:58 PST
                                                         Re: Repository Browser not working steveking Stefan Küng 2012-01-21 12:02:48 PST
                                         Re: Re: Repository Browser not working simonlarge Simon Large 2012-01-16 04:41:09 PST
                                 Re: Re: Repository Browser not working simonlarge Simon Large 2012-01-14 14:46:16 PST
         Re: Repository Browser not working Dave Huang <khym at azeotrope dot org> Dave Huang <khym at azeotrope dot org> 2012-01-05 16:43:49 PST
             Re: Repository Browser not working Dave Huang <khym at azeotrope dot org> Dave Huang <khym at azeotrope dot org> 2012-01-05 16:54:54 PST
                 RE: Re: Repository Browser not working miqrogroove Robert Chapin 2012-01-05 17:32:30 PST
                     Re: Re: Repository Browser not working simonlarge Simon Large 2012-01-06 01:06:09 PST
                         RE: Re: Re: Repository Browser not working miqrogroove Robert Chapin 2012-01-06 08:46:10 PST
Messages per page: