Login | Register
My pages Projects Community openCollabNet

Discussions > users > RE: Re: Re: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?)

Project highlights: :. Download .: :. Support .: :. FAQ .: :. Translations .: :. Donate .: :. Report Bug .:

tortoisesvn
Discussion topic

Back to topic list

RE: Re: Re: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?)

Author david81
Full name David Hinken
Date 2016-05-09 05:33:25 PDT
Message > On 9 May 2016 at 15:03, David Hinken <d dot hinken at isfh dot de> wrote:
> >> > Ivan suggested to use the svn command-line tool. I just tried it using a batch file
> >> > and passed all 1000 text files to 'svn lock a b c ...'. It works fine without any trouble!
> >> > It seems to work file-by-file and thus takes is slower is quite slow but work without problem.
> >> It's really strange, because TortoiseSVN uses the same API in the same
> >> way as Subversion command line client.
> >>
> >> What svn.exe version you're testing? You may use 'svn.exe --version'
> >> command to find Subversion command line client version.
> >
> > Sorry, my mistake, I had two versions of subversion installed.
> >
> > svn version 1.8.13 (r1667537) works file-by-file and works without any problem.
> >
> > svn version 1.9.4 (r1740329) shows a similar behaviour as TSVN. It tries to lock
> > about 30-40 files at once and then hangs without any sign of progress.
> >
> Does it hang after successfully locking 30-40 files or it doesn't work
> completely when attempt to lock more than 30-40 files at once?

Not sure. I attempt to lock about 1000 files. It seems that the first 30-40 files are locked correctly 'Message is: Locked by ...'. Then it hangs for about 5 minutes and after that continues. I then have a lock for nearly all of the files except for some, which are locked but 'in another working copy', as stated by svn. For these files I have to break the locks.


> >> I'm not familiar with Java-Tunnel. Could you please share URL you're
> >> using to checkout Subversion working copy.
> >
> > The URL is
> > https://localhost:35​741/svn/Test
> >
> > and redirects via the Java-Tunnel (running in Firefox) to the SVN server.
> >
> Now it's more clear: Java-Tunnel acts as a proxy and forwards all
> requests to SVN Server. The most likely problem that Java-Tunnel
> doesn't implement HTTP pipelining [1] properly. HTTP pipelining is a
> technique in which multiple HTTP requests are sent on a single TCP
> connection without waiting for the corresponding responses. svn
> lock/unlock uses HTTP pipelining to lock/unlock multiple files since
> Subversion 1.9.0. HTTP pipelining is also used by 'svn checkout', but
> this can be disabled on server or client-side.
>
> I suggest you report this problem to Java-Tunnel developers.

HTTP pipelining can only be disabled for 'svn checkout' and not for 'svn lock' ?

Okay, great, this is a good hint to the problem. I will try to contact with the Java-Tunnel developers.

Thanks to all of you for the fast support!

« Previous message in topic | 17 of 27 | Next message in topic »

Messages

Show all messages in topic

TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) david81 David Hinken 2016-05-04 01:58:41 PDT
     Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) Stefan Hett <stefan at egosoft dot com> Stefan Hett <stefan at egosoft dot com> 2016-05-04 02:34:40 PDT
         RE: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) david81 David Hinken 2016-05-04 04:59:16 PDT
             Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) Stefan Hett <stefan at egosoft dot com> Stefan Hett <stefan at egosoft dot com> 2016-05-04 05:29:14 PDT
                 RE: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) david81 David Hinken 2016-05-04 06:04:36 PDT
                 RE: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) david81 David Hinken 2016-05-04 10:47:19 PDT
                     Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) Stefan Hett <stefan at egosoft dot com> Stefan Hett <stefan at egosoft dot com> 2016-05-06 03:07:23 PDT
                         Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) Stefan Hett <stefan at egosoft dot com> Stefan Hett <stefan at egosoft dot com> 2016-05-06 04:12:08 PDT
                             Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) steveking Stefan Küng 2016-05-06 04:34:59 PDT
                                 Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) Stefan Hett <stefan at egosoft dot com> Stefan Hett <stefan at egosoft dot com> 2016-05-06 04:43:03 PDT
                                     Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) steveking Stefan Küng 2016-05-06 05:28:13 PDT
                                         Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) Stefan Hett <stefan at egosoft dot com> Stefan Hett <stefan at egosoft dot com> 2016-05-06 05:34:47 PDT
                                             RE: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) david81 David Hinken 2016-05-09 04:29:20 PDT
                                                 Re: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) Ivan Zhakov <ivan at visualsvn dot com> Ivan Zhakov <ivan at visualsvn dot com> 2016-05-09 04:40:03 PDT
                                                     RE: Re: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) david81 David Hinken 2016-05-09 05:03:20 PDT
                                                         Re: Re: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) Ivan Zhakov <ivan at visualsvn dot com> Ivan Zhakov <ivan at visualsvn dot com> 2016-05-09 05:18:28 PDT
                                                             RE: Re: Re: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) david81 David Hinken 2016-05-09 05:33:25 PDT
                                                                 Re: Re: Re: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) Ivan Zhakov <ivan at visualsvn dot com> Ivan Zhakov <ivan at visualsvn dot com> 2016-05-09 06:12:17 PDT
                                                                     RE: Re: Re: Re: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) david81 David Hinken 2016-05-10 06:32:38 PDT
                                 RE: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) david81 David Hinken 2016-05-09 04:48:44 PDT
                                     Re: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) Ivan Zhakov <ivan at visualsvn dot com> Ivan Zhakov <ivan at visualsvn dot com> 2016-05-09 05:00:43 PDT
                                         RE: Re: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) david81 David Hinken 2016-05-09 05:10:18 PDT
                                             RE: Re: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) david81 David Hinken 2016-05-09 05:23:16 PDT
                                                 Re: Re: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) Ivan Zhakov <ivan at visualsvn dot com> Ivan Zhakov <ivan at visualsvn dot com> 2016-05-09 06:04:51 PDT
                                                     RE: Re: Re: Re: TortoiseSVN "Get lock" of multiple files fails via Java-SSL-tunnel since v1.9.0 (bug?) david81 David Hinken 2016-05-09 06:20:33 PDT
Page: of 2 « Previous | Next »
Messages per page: