Login | Register
My pages Projects Community openCollabNet

Discussions > users > RE: Re: Cannot get revison graph

Project highlights: :. Download .: :. Support .: :. FAQ .: :. Translations .: :. Donate .: :. Report Bug .:

tortoisesvn
Discussion topic

Hide all messages in topic

All messages in topic

Re: Cannot get revison graph

Author steveking
Full name Stefan Küng
Date 2011-05-04 12:29:58 PDT
Message On 03.05.2011 03:31, Peter Koves wrote:
>> The revision graph has to fetch the log from the repository root. Check
>> the Apache error log for hints about what went wrong here.
>> Maybe you have to add a slash in your Apache config for the<Location
>> svn/> block.
>>
>> Stefan
>
>
> Thanks for the pointer. This certainly seems the problem as the same thing happens when I try to do a 'Show Log' for the root of the working copy. I tried the following including combinations of the commented out directives, but this did not help.
>
> <Location /svn/>
> DAV svn
> SVNReposName "Peter's Subversion Repositories"
> SVNParentPath /opt/share/SVN
> # RedirectMatch ^(/svn)$ $1/
> # SVNListParentPath on
> AuthType Basic
> AuthName "Subversion Repository"
> SVNPathAuthz off
> AuthUserFile /opt/share/SVN/svn-auth-file
> Require valid-user
> </Location>

try <Location /svn> instead of <Location /svn/>.
If that doesn't work, you should ask on the svn users list for help
since this is an issue with server setup.

Stefan

--
        ___
   oo // \\ "De Chelonian Mobile"
  (_,\/ \_/ \ TortoiseSVN
    \ \_/_\_/> The coolest Interface to (Sub)Version Control
    /_/ \_\ http://tortoisesvn.net

RE: Re: Cannot get revison graph

Author kovesp
Full name Peter Koves
Date 2011-05-02 18:31:13 PDT
Message > The revision graph has to fetch the log from the repository root. Check
> the Apache error log for hints about what went wrong here.
> Maybe you have to add a slash in your Apache config for the <Location
> svn/> block.
>
> Stefan


Thanks for the pointer. This certainly seems the problem as the same thing happens when I try to do a 'Show Log' for the root of the working copy. I tried the following including combinations of the commented out directives, but this did not help.

<Location /svn/>
   DAV svn
   SVNReposName "Peter's Subversion Repositories"
   SVNParentPath /opt/share/SVN
# RedirectMatch ^(/svn)$ $1/
# SVNListParentPath on
   AuthType Basic
   AuthName "Subversion Repository"
   SVNPathAuthz off
   AuthUserFile /opt/share/SVN/svn-auth-file
   Require valid-user
</Location>

Re: Cannot get revison graph

Author steveking
Full name Stefan Küng
Date 2011-05-02 10:16:24 PDT
Message On 01.05.2011 18:55, Peter Koves wrote:
> Context: I was using TSVN to connect to a local repository over HTTP. I just switched to having the repository on a Synology NAS, again via HTTP. User authentication is enabled (seems required in order to use locks). Everything is working fine as before except I cannot get a revision graph.
>
> When I try, the "Want to go offline?" dialog is displayed. When I cancel that I get an error dialog with the text "REPORT of '/svn/Sparx/!svn/bc/285':200 OK (http://my.server.org:443)". [ The http: protocol is correct despite the fact that I am using it over port 443 ].
>
> The version controlled file itself is called 'Misc Models.xml' and is at the top level of the working copy which corresponds to the trunk in the repository.
>
> On the NAS ... (these arethe latest version available for the device)
> The svn version is:
> svn, version 1.6.15 (r1038135)
> compiled Nov 25 2010, 23:41:30
> The apache version is: 2.2.17-1
>
> On the client the TSVN version is
> TortoiseSVN 1.6.15, Build 21042 - 64 Bit , 2011/03/23 18:57:14
> Subversion 1.6.16,
>
> Am I doing something wrong? Can this be fixed?

The revision graph has to fetch the log from the repository root. Check
the Apache error log for hints about what went wrong here.
Maybe you have to add a slash in your Apache config for the <Location
svn/> block.

Stefan

--
        ___
   oo // \\ "De Chelonian Mobile"
  (_,\/ \_/ \ TortoiseSVN
    \ \_/_\_/> The coolest Interface to (Sub)Version Control
    /_/ \_\ http://tortoisesvn.net

Cannot get revison graph

Author kovesp
Full name Peter Koves
Date 2011-05-01 09:55:56 PDT
Message Context: I was using TSVN to connect to a local repository over HTTP. I just switched to having the repository on a Synology NAS, again via HTTP. User authentication is enabled (seems required in order to use locks). Everything is working fine as before except I cannot get a revision graph.

When I try, the "Want to go offline?" dialog is displayed. When I cancel that I get an error dialog with the text "REPORT of '/svn/Sparx/!svn/bc/285':200 OK (http://my.server.org:443)". [ The http: protocol is correct despite the fact that I am using it over port 443 ].

The version controlled file itself is called 'Misc Models.xml' and is at the top level of the working copy which corresponds to the trunk in the repository.

On the NAS ... (these arethe latest version available for the device)
The svn version is:
svn, version 1.6.15 (r1038135)
   compiled Nov 25 2010, 23:41:30
The apache version is: 2.2.17-1

On the client the TSVN version is
TortoiseSVN 1.6.15, Build 21042 - 64 Bit , 2011/03/23 18:57:14
Subversion 1.6.16,

Am I doing something wrong? Can this be fixed?
Messages per page: