Login | Register
My pages Projects Community openCollabNet

Discussions > dev > Re: LogFindCopyFrom not working as expected

Project highlights: :. Download .: :. Support .: :. FAQ .: :. Translations .: :. Donate .: :. Report Bug .:

tortoisesvn
Discussion topic

Back to topic list

Re: LogFindCopyFrom not working as expected

Author Stefan Hett <stefan at egosoft dot com>
Full name Stefan Hett <stefan at egosoft dot com>
Date 2016-08-08 04:17:38 PDT
Message On 8/8/2016 1:16 PM, Stefan Hett wrote:
> Hi Sven,
> On 8/8/2016 1:02 PM, "Sven Brüggemann" wrote:
>> Hello,
>>
>> when my repository was at revision 40000, I created a branch from
>> trunk revision 39800 and checked out a working copy of this branch.
>>
>> When trying to merge some trunk revisions into that working copy, the
>> "Show log" button for the source URL initially doesn't show any logs
>> ("For complete history deselect 'Stop on copy/rename'"). Expected
>> behaviour: Show trunk logs from revision 39801 to HEAD.
>>
>> When deselecting 'Stop on copy/rename' all trunk logs are shown but
>> they are all greyed out as if they were already merged. Expected
>> behaviour: Show unmerged revisions in black and merged revisions
>> grayed out.
>>
>> Since the command line client gives the expected results for "svn
>> mergeinfo --show-revs eligible [trunk-URL] ." I think this is
>> actually a TSVN problem.
>>
>> TSVN 1.9.4 Build 27285 64 Bit on Win 8.1 Pro, LogFindCopyFrom set to
>> "true"
>> Server is svnserve 1.8.13 1667537 (Linux)
>>
>> Kind regards
>>
> Are you 100% certain you are specifying the correct URLs in the merge
> dialog and that your WC you want to merge trunk back into is at the
> branch (at the right revision) and the other revisions haven't been
> merged back (or blocked) in the branch yet?
> Are you 100% sure that when you created the branch from trunk you
> explicitly specified to use revision 39800 (instead of HEAD or the
> current WC revision)?
>
> Any chance you could provide some screenshots depicting the set up you
> have and directly demonstrating TSVN's behavior?
>
> I'm asking here, because I use that process on a daily basis here and
> never had such problems, unless I made some mistake (like mixing up
> the URL and or forgetting to specify the correct revision when
> creating a branch from a different revision than HEAD).
>
Also I just realized you sent this to the dev list. Maybe you'd be
better of to ask this on the users list, since there more people are
following and this is a question more suitable for the users list than
the dev list IMO.

--
Regards,
Stefan Hett

« Previous message in topic | 3 of 8 | Next message in topic »

Messages

Show all messages in topic

LogFindCopyFrom not working as expected svenb Sven Brüggemann 2016-08-08 04:02:16 PDT
     Re: LogFindCopyFrom not working as expected Stefan Hett <stefan at egosoft dot com> Stefan Hett <stefan at egosoft dot com> 2016-08-08 04:16:15 PDT
         Re: LogFindCopyFrom not working as expected Stefan Hett <stefan at egosoft dot com> Stefan Hett <stefan at egosoft dot com> 2016-08-08 04:17:38 PDT
         Aw: Re: LogFindCopyFrom not working as expected svenb Sven Brüggemann 2016-08-09 00:20:42 PDT
             Re: Re: LogFindCopyFrom not working as expected svenb Sven Brüggemann 2016-08-17 02:22:10 PDT
                 Re: LogFindCopyFrom not working as expected steveking Stefan Küng 2016-08-18 11:41:37 PDT
                     Re: LogFindCopyFrom not working as expected steveking Stefan Küng 2016-08-19 13:21:41 PDT
                         Aw: Re: LogFindCopyFrom not working as expected svenb Sven Brüggemann 2016-08-22 00:26:15 PDT
Messages per page: