Login | Register
My pages Projects Community openCollabNet

Discussions > dev > Aw: Re: LogFindCopyFrom not working as expected

Project highlights: :. Download .: :. Support .: :. FAQ .: :. Translations .: :. Donate .: :. Report Bug .:

tortoisesvn
Discussion topic

Back to topic list

Aw: Re: LogFindCopyFrom not working as expected

Author svenb
Full name Sven Brüggemann
Date 2016-08-09 00:20:42 PDT
Message Hello,

> > when my repository was at revision 40000, I created a branch from trunk revision 39800 and checked out a working copy of this branch.
> >
> > When trying to merge some trunk revisions into that working copy, the "Show log" button for the source URL initially doesn't show any logs ("For complete history deselect 'Stop on copy/rename'"). Expected behaviour: Show trunk logs from revision 39801 to HEAD.
> >
> > When deselecting 'Stop on copy/rename' all trunk logs are shown but they are all greyed out as if they were already merged. Expected behaviour: Show unmerged revisions in black and merged revisions grayed out.
> >
> > Since the command line client gives the expected results for "svn mergeinfo --show-revs eligible [trunk-URL] ." I think this is actually a TSVN problem.
> >
> > TSVN 1.9.4 Build 27285 64 Bit on Win 8.1 Pro, LogFindCopyFrom set to "true"
> > Server is svnserve 1.8.13 1667537 (Linux)
> >
> > Kind regards
> >
> Are you 100% certain you are specifying the correct URLs in the merge
> Are you 100% sure that when you created the branch from trunk you

Yes for both. And the command line client gives the expected results.

> Any chance you could provide some screenshots depicting the set up you
> have and directly demonstrating TSVN's behavior?

Please see the attached pictures. The actual revisions are:
HEAD: 37582
Branch created in revision 37578 from trunk revision 36666.
Expected behaviour:
- Do not stop at revision 37578 but at revision 36666
- Show trunk revisions 36667 to HEAD in black instead of grayed out

Kind regards
Attachments

« Previous message in topic | 4 of 8 | Next message in topic »

Messages

Show all messages in topic

LogFindCopyFrom not working as expected svenb Sven Brüggemann 2016-08-08 04:02:16 PDT
     Re: LogFindCopyFrom not working as expected Stefan Hett <stefan at egosoft dot com> Stefan Hett <stefan at egosoft dot com> 2016-08-08 04:16:15 PDT
         Re: LogFindCopyFrom not working as expected Stefan Hett <stefan at egosoft dot com> Stefan Hett <stefan at egosoft dot com> 2016-08-08 04:17:38 PDT
         Aw: Re: LogFindCopyFrom not working as expected svenb Sven Brüggemann 2016-08-09 00:20:42 PDT
             Re: Re: LogFindCopyFrom not working as expected svenb Sven Brüggemann 2016-08-17 02:22:10 PDT
                 Re: LogFindCopyFrom not working as expected steveking Stefan Küng 2016-08-18 11:41:37 PDT
                     Re: LogFindCopyFrom not working as expected steveking Stefan Küng 2016-08-19 13:21:41 PDT
                         Aw: Re: LogFindCopyFrom not working as expected svenb Sven Brüggemann 2016-08-22 00:26:15 PDT
Messages per page: