Login | Register
My pages Projects Community openCollabNet

Discussions > dev > please help - SharpSvn problem Question

Project highlights: :. Download .: :. Support .: :. FAQ .: :. Translations .: :. Donate .: :. Report Bug .:

tortoisesvn
Discussion topic

Back to topic list

please help - SharpSvn problem Question

Author yzion <yosi dot zi at eldan dot co dot il>
Full name yzion <yosi dot zi at eldan dot co dot il>
Date 2017-01-31 04:50:54 PST
Message Hello

I am developing in *C # with visual studio 2013,2015 *and have a particular
problem with SharpSvn and I hope someone can solve it for me.

Installs and downloads:
1.
I installed *VisualSvnServer Version: 3.5.7* on a virtual server with the
following settings:
Authentication tab - integrated windows authentication
Security tab - add permissions to my user (my user is administrator)
Certificate tab - change to my company certificate
Network tab - I use secure connection (https: //) with port 443
I add admin permission to the repository root

2. Client Side
*TortoiseSVN 1.9.5, Build 27581-64 Bit*
And *AnkhSvn-2.6.12735
*
3. I downloaded the latest version of SharpSvn (SSvn-1.9005.3934.158-x64)

Problem Description:
When I'm trying to merge through the UI TortoiseSVN everything works fine
and it perform the merge and the commit to the repository/
When I try to do this through C# code with SharpSvn I get a message "Unable
to connect to a repository at URL
'https://MyServer.co.​il/svn/noam2/Yosi/No​rthwindTrunk2/Trunk'​"
After call client.Merge(qa_work_copy, mergeFrom, revisionsRange, mergeArgs);
I think I tried everything:
I tried without Authentication of user and password
I tried Authentication of user and password via
client.Authenticatio​n.ForceCredentials
I signed up for all the events of Authentication and some even not fired,
For example:
SharpSvn.Security.Sv​nSslServerTrustEvent​Args
Authentication_SslCl​ientCertificatePassw​ordHandlers

I even set the DefaultCredentials via System.Net.NetworkCr​edential(user,
password) without any success

Incidentally, I am successful to perform the Update action using an SharpSvn

I enclose you snippets of code I wrote to those who succeeded and those that
failed
I do not know what to do about it and the more I will be happy if you can
help me solve this problem.

Thanks
yosi

<http://tigris-scm.10​930.n7.nabble.com/fi​le/n101534/2017-01-3​1_14h38_33.png>
<http://tigris-scm.10​930.n7.nabble.com/fi​le/n101534/2017-01-3​1_14h39_11.png>
<http://tigris-scm.10​930.n7.nabble.com/fi​le/n101534/2017-01-3​1_11h41_34.png>
<http://tigris-scm.10​930.n7.nabble.com/fi​le/n101534/2017-01-3​1_11h39_48.png>
<http://tigris-scm.10​930.n7.nabble.com/fi​le/n101534/2017-01-3​1_11h38_31.png>
<http://tigris-scm.10​930.n7.nabble.com/fi​le/n101534/2017-01-3​1_14h39_53.png>
<http://tigris-scm.10​930.n7.nabble.com/fi​le/n101534/2017-01-3​1_14h39_22.png>



--
View this message in context: http://tigris-scm.10​930.n7.nabble.com/pl​ease-help-SharpSvn-p​roblem-Question-tp10​1534.html
Sent from the tortoisesvn - dev mailing list archive at Nabble.com.

« Previous message in topic | 1 of 1 | Next message in topic »

Messages

Show all messages in topic

please help - SharpSvn problem Question yzion <yosi dot zi at eldan dot co dot il> yzion <yosi dot zi at eldan dot co dot il> 2017-01-31 04:50:54 PST
Messages per page: